Jump to content


Photo

Dead LX850

lx800

  • Please log in to reply
2 replies to this topic

#1 Loden1111

Loden1111

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 01 February 2015 - 07:40 PM

A little over a week ago (one year and three weeks after purchase) while traversing the Starlock cable hung on the mount. While it did not break or even crack the plug housings, it did stop the mount. When I attempted to reverse the slew to release the cable, the handset was non-responsive and read "DOWNLOADING. DO NOT TURN OFF." I released the clutches to unhang the cable and upon returning to the hand paddle found it dead. The telescope control panel light was out and cycling the switch produces no effect. I have checked the power supply and it is producing 12v as it should. I did a continuity check on the Starlock cable, and it appears to be shorted on all leads. 

 

I called Meade and at the request of the service rep, provided them with my proof of purchase and a detailed writeup. Despite several emails and another call, I have heard nothing back in a week. Any suggestions? Is it normal for Meade to take more than a week to respond to a dead mount?

 

I have found where I can order another Telescope Control Box, but have been unable to find a replacement Starlock cable online. 



#2 jrcrilly

jrcrilly

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts

Posted 01 February 2015 - 07:49 PM

I haven't looked behind the panel on my LX850 but on earlier models using basically the control panel (with all the sockets and jacks) the main DC fuse was behind it. Might be worth taking a look. Should be a 2A sloblow. Based on the message you reported, you may have to reload the firmware to get it working again. Leave the Starlock cable unplugged for now (the mount will work without it; you just won't have Starlock functions). The pinouts for that cable have been published in this forum; maybe someone remembers in which thread that appeared..



#3 Loden1111

Loden1111

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 02 February 2015 - 03:39 PM

Disregard. Meade did come through today. I called and they have approved a warranty repair despite it being three weeks out of date. Was quite a hassle to get the head properly boxed and cushioned (had to buy a roughneck storage bin), but now it is just waiting (hopefully). Lesson learned: Even with the Starlock cable running through the mount it still has a bit of slack in it, and anything that can hang will hang. Fortunately I have my old Orion EQ-G mount and can return to yesteryear to at least get some good wide fields while I am waiting. 


  • Mark Sibole and RickScofield like this





Also tagged with one or more of these keywords: lx800

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users