Jump to content


Photo

DS2114 LNT Handbox dead


  • Please log in to reply
5 replies to this topic

#1 nightwolf364

nightwolf364

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationShoreline, WA

Posted 28 February 2014 - 05:11 PM

Yesterday I turned my scope on to set it to 00 then turned it off again to save the batteries until I use it again later on.  Today I went to turn it on and the handbox went completely dead.  Anyone have any ideas?


  • Neracellver likes this

#2 MistrBadgr

MistrBadgr

    Advanced Member

  • Administrators
  • 2681 posts
  • LocationBroken Arrow, Oklahoma

Posted 28 February 2014 - 08:50 PM

Check all the connections to the handset.  Plug and unplug them a time or two to make sure the contacts are clean.  Do the same with the battery connections.  It sounds like it simply is not getting power somehow......at least I hope so.

 

Bill Steen


  • Neracellver likes this
Bill Steen, Sky Hunters' Haven Observatory, Broken Arrow, Oklahoma

#3 nightwolf364

nightwolf364

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationShoreline, WA

Posted 01 March 2014 - 03:33 PM

The red light is on and I replaced the batteries the othe day, so it is not the batteries.



#4 MistrBadgr

MistrBadgr

    Advanced Member

  • Administrators
  • 2681 posts
  • LocationBroken Arrow, Oklahoma

Posted 01 March 2014 - 06:15 PM

I suspect the problem is either a connection issue with the cord or something went bad in the handset.  You might want to contact Meade Customer Support at 1-800-626-3233.  If your scope is still under warranty, they should be able to send you another handset.  If you have know someone else that has a Meade scope with an AutoStar handset, it should work with your mount to see if there is any issue with the mount.  A 494 or 497 handset should work just fine.

 

Bill Steen


Bill Steen, Sky Hunters' Haven Observatory, Broken Arrow, Oklahoma

#5 nightwolf364

nightwolf364

    Newbie

  • Members
  • Pip
  • 3 posts
  • LocationShoreline, WA

Posted 22 March 2014 - 10:27 PM

I received it as a gift and I am pretty sure the warranty is dead on the scope.



#6 MistrBadgr

MistrBadgr

    Advanced Member

  • Administrators
  • 2681 posts
  • LocationBroken Arrow, Oklahoma

Posted 23 March 2014 - 02:48 PM

What you need is another 494 handset, that is known to be good, to plug into the mount and see if it works.  Do you know anyone in your area that has one?  If so, maybe you could borrow it for a little while, or take your handset and plug it into their mount and see if it works that way.

 

You still might want to call Meade Customer Support and see if they have any ideas of things to try.

 

Bill Steen


Bill Steen, Sky Hunters' Haven Observatory, Broken Arrow, Oklahoma




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users