Jump to content


Photo

My LX600 issues - update


  • Please log in to reply
6 replies to this topic

#1 tlwarnke

tlwarnke

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 26 June 2013 - 08:34 AM

I received my 10" LX600 from Astronomics a few weeks after they generally started shipping. I started having issues as soon as I had it up and running. First, the RA slow-motion control knob would rub against the base. (Apparently the knob was too long.) I called Meade but they hadn't heard of the problem. So I took it on myself loosened the hex screw and raised the knob up a bit. Not very elegant but then I don't use the knob very much.
Then I started having issues with RA gears binding when I moved the scope manually. I move the scope manually when I am initially setting it up so I can polar align. I called Meade to report this issue. They asked if I had the problem when running it with the hand controller. I replied that I did not. I was ask to just use the hand controller instead of manually moving it. I replied, would Meade be willing to offset the resale price, due to the issue, down the road if/when I want to sell the scope. No they were not. Then they emailed me a shipping label to send just the base back to them, at my expense! No effing way on that baby. Hey, this is a new product! Not my fault you didn't do any QA. OK., they want me to send the base back on their dime. Fine with me. I was told it would take 3-4 weeks but they would see if it could be expedited. I shipped it on June 12.
Well, the LX600 base arrived at the shipping address on June 18. I wasn't told that it would take another 3 days to get to the real destination. I called Meade support on June 24 to just check on the status. Yes, they received it. This is when I found out they really didn't get it until June 21. Now I was told it could take 5-6 weeks before I get it back. WTF? Guess no expediting there.
Frankly, I think Meade should either fix the LX600 base promptly or send me a new base (preferred). Also, due to their lack of QA, they should extend my warranty by a year.
Anyway, since I received to LX600 I only had it out twice. Mainly because the gear binding issue but also due to weather and that thing is a beast and I need help moving it around.

Thank you Meade (Not)


Terry

Still waiting to use my LX600.
Yes, I will keep bugging Meade until I get my equipment back. Repaired or new.

#2 tlwarnke

tlwarnke

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 28 June 2013 - 05:26 AM

I received good news from Meade yesterday. My equipment is on the repair table and should be shipped back next week.
I guess it is true about the squeaky wheel.

Terry

#3 Cryhavoc

Cryhavoc

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts

Posted 28 June 2013 - 05:22 PM

LOL. Very true!

#4 MistrBadgr

MistrBadgr

    Advanced Member

  • Administrators
  • 2828 posts
  • LocationBroken Arrow, Oklahoma

Posted 28 June 2013 - 07:25 PM

Even if it does not get you a place in line ahead of anyone else, it is bound to improve your chances of a personal update if it can decrease their impalpable pain.

Bill Steen
Bill Steen, Sky Hunters' Haven Observatory, Broken Arrow, Oklahoma

#5 tlwarnke

tlwarnke

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 05 July 2013 - 06:11 PM

Well it appears Meade was stretching the truth a bit. Was told last week it would ship early this week. Then I was told because of the 4th of July holiday it won't be shipped back until next week. I guess Thursday is considered early in the week.

Terry

#6 tlwarnke

tlwarnke

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 17 July 2013 - 11:29 AM

I received the base of my LX600 back from Meade repair. Just to dang hot and humid out to test if they fixed the problem. Hopefully, this weekend as the forecast is for some decent conditions. Fingers crossed.

Terry

#7 tlwarnke

tlwarnke

    Advanced Member

  • Members
  • PipPipPip
  • 54 posts

Posted 14 September 2013 - 04:48 PM

I guess I should have reported back sooner. Everything that was reported to Meade as an issue was fixed. The problem was the some gearing was missed aligned and was rubbing on something. The scope rotates smoothly now. The views through the scope are amazingly sharp. Still trying to learn things. Haven't been many night good enough to get out and play with it. Hopefully now that fall is coming I will have clear and crisp nights.

Terry




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users