Jump to content


Autostar Controller Locked Up & Unresponsive

  • Please log in to reply
1 reply to this topic

#1 cyastrzemski



  • Members
  • Pip
  • 3 posts

Posted 22 June 2011 - 03:41 PM

My DSX-90 Autostar controller locked up and is unresponsive. Upon power up it displays the Autostar greeting and software version ©0.6 MEADE [43E] AUTOSTAR, then beeps, displays the Welcome to AUTOSTAR message and then the following:
Speed = 0.5 deg/sec
or MODE for Menu

None of the buttons respond at this point other than the up/down/left/right motor buttons which will move the mount in the 0.5 deg/sec speed.

I thought maybe the batteries were losing juice so I replaced them with new ones and still no response. The display is nice and bright.

Any ideas?

Regards,  Ed

#2 hargy


    Advanced Member

  • Members
  • PipPipPip
  • 171 posts

Posted 23 June 2011 - 07:07 AM

have you tried replacing the cable. or cleaning the prongs with alcohol.
LX200R 10 inch Semi Peir Mount, Willam Optics 2.5 inch Guide Scope. Orion Auto Guider CCD. Meade DSI II Pro CCD. Deepsky Stacker, PhotoShop 5.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users