Jump to content


Photo

LS-8 Autostar III


  • Please log in to reply
1 reply to this topic

#1 tmohr36

tmohr36

    Advanced Member

  • Members
  • PipPipPip
  • 44 posts
  • LocationNorth Las Vegas

Posted 15 November 2010 - 04:56 PM

So, I received my LS - 8 scope back at the end of September, everything set up nicely, got it to turn on, do the gps dance, find north, align and goto. When the "astronomer inside" told me to push the back button or media button, I found it quite odd that I didn't have those buttons. I dismissed the whole thing because the Mode and ? buttons on my Handbox worked just fine for those functions....

Now I've been getting handbox lockups frequently and have become disappointed when it does due to the fact that I have to power cycle the telescope and wait for a full alignment process each time.

Searching through the LS Manual, I found that I should have an Autostar III handbox not the supplied Autostar II handbox that came in the scope box. The handbox shows the current software version and does everthing it's supposed to, just I paid for Autostar III and got Autostar II. Anyone else have the same thing happen or similar issue?

#2 MistrBadgr

MistrBadgr

    Advanced Member

  • Administrators
  • 2744 posts
  • LocationBroken Arrow, Oklahoma

Posted 21 November 2010 - 09:18 AM

I would call Meade Curstomer Support on this one.  If it does not have a button it is supposed to have, which makes it pretty straight forward that someone made a mistake, either in the instructions or with the handset, then it needs to be corrected.

There have been issues with some of the eariler versions of the software in the handset with it locking up.  I had not had any trouble with mine until recently, when I tried to play the media while actually looking at an object instead of before the scope traveled to it.  I have version 1.4 in mine and need to load the current version.  Other than that, my scope has worked perfectly.

When I have called customer support for anything during the last year, I have gotten a real live person rather than having to leave a message or anything like what I have had with some other companies.  Most of the time, someone answers the phone right off with no waiting.  I call them, sometimes to get a question answered for someone posting on this forum.  As I post this, it is Sunday and they are not there.

Give them a call.  I do not remember the number off the top of my head right now.  You can find it, I believe, on the Meade.com website under customer support.

Hope this helps,


Bill Steen
Bill Steen, Sky Hunters' Haven Observatory, Broken Arrow, Oklahoma




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users