Jump to content


Photo

LXD75 Gears


  • Please log in to reply
6 replies to this topic

#1 cannon

cannon

    Advanced Member

  • Members
  • PipPipPip
  • 208 posts
  • LocationFlorida

Posted 09 August 2008 - 07:26 PM

I just picked up a new LXD75 mount. The DEC has a brass gear on the motor and a silver on the worm. But the RA has a silver on both. Can someone that has this mount check thiers and see if this is correct or did I get a mount that was not assembled right. I don't have anything mounted on it to test it.

#2 DSOMAN

DSOMAN

    Advanced Member

  • Members
  • PipPipPip
  • 329 posts

Posted 09 August 2008 - 10:17 PM

I had the same on my LXD75. I think Meade has the same gears made from different metals and they mix them up.

Brent

#3 cannon

cannon

    Advanced Member

  • Members
  • PipPipPip
  • 208 posts
  • LocationFlorida

Posted 13 August 2008 - 03:57 PM

Brent,
Thanks for the input on yours. Anyone else own one of these that can give more input?

#4 grimzella

grimzella

    Member

  • Members
  • PipPip
  • 10 posts

Posted 21 August 2008 - 01:05 PM

my original one had all brass gears... well it went bad... shipped back... and then got replacement... it had  one of each... a brass,, and a silver on each.  so i guess it dont matter... as far as meade is concerned.

#5 cannon

cannon

    Advanced Member

  • Members
  • PipPipPip
  • 208 posts
  • LocationFlorida

Posted 22 August 2008 - 03:46 PM

From what I can see on the DEC, the motor gear (Brass) is smaller than that the worm gear (silver). On the RA they are both silver and both gears look to be the same size. I have had several of these mounts and don't recall this. I may be wrong though.

#6 george2455

george2455

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts

Posted 28 August 2008 - 03:03 PM

Hi There....Both of my drives have brass and 1 silver.  Tried to tighten the set screw on one of the brass ones but couldn't get the allen wrench to fit.  Looks like someone tried before and muddled the socket.....george

#7 SmokeyJoe

SmokeyJoe

    Newbie

  • Members
  • Pip
  • 8 posts
  • LocationGreat Lakes Region, N.A.

Posted 08 October 2016 - 07:46 AM

On my unit, both axes have one brass and one aluminum(?). 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users