Jump to content


Tracking Motor Stopped Working!


  • Please log in to reply
4 replies to this topic

#1 Guest_davidleejenkins_*

Guest_davidleejenkins_*
  • Guests

Posted 07 May 2008 - 02:15 PM

Help!  The other night, to my surprise, the Tracking Motor in Right Ascension on my 12" RCX400 stopped working, nor could I slew the scope in R.A., even though Declination still works.  I can move the scope manually, but it will no longer track objects.  At first I thought it might be the Autostar II buttons, but they work on other features, such as focusing.  I'm guessing that the problem is a burned out tracking motor or a problem with the board.  I phoned Meade's Customer Support and they are asking me to return the scope for repair.  Even though the scope is under warranty (10 months old), I am responsible for all costs related to shipping, insurance, and brokerage.  I live near Toronto, Ontario, Canada and UPS has quoted me $1,271.77 just to get the scope to Meade.  After Meade repairs the scope, I will be responsible for brokerage fees back into Canada which will likely cost me another $300.00.  This is SO FRUSTRATING!  For a telescope that is under warranty, I am going to have to pay over $1,500.00 with no guarantee that this won't happen again in the future.  Are there any other options for me?  Why won't Meade allow their dealers in Canada do repairs so that I can avoid all of these exhorbitant costs?  Is there another mount I can buy to replace the one from Meade?  I need more cost effective options.  Please help!

#2 autostaretx

autostaretx

    Advanced Member

  • Members
  • PipPipPip
  • 206 posts

Posted 07 May 2008 - 09:37 PM

I'd turn the scope over, remove the bottom plate and *look*
for obvious things such as a loose or disconnected cable
or connector.

Totally dead drives are usually due to very simple causes

Example of opening a 10" LX200gps:
http://rseymour.home.../LX200guts.html

good luck
--dick

#3 autostaretx

autostaretx

    Advanced Member

  • Members
  • PipPipPip
  • 206 posts

Posted 07 May 2008 - 09:42 PM

other thoughts (for the future):
Does Meade offer the Sky Assurance warranty package in Canada?

One flavor of it has -them- paying for both directions of shipping.

You might also inquire of Canadian Customs if they have provision for
high-value goods leaving and returning.  In the US, you can get such
things noted on a Customs form (with serial number, etc) demonstrating
that they were already in-country (hence duty already paid), and that
they're leaving temporarily and shall return.  Upon their return,
the paper proves you don't have to pay duty the second time.

For the US clearance of that sort (frequently used for cameras
going out and back with tourists) you take the item to a Customs
office, and it's a while-you-wait fast procedure.

good luck (if you need to do that)
--dick

#4 Guest_davidleejenkins_*

Guest_davidleejenkins_*
  • Guests

Posted 08 May 2008 - 04:32 AM

Thank you for your suggestions.  I will remove the plate and take a look to see if I can spot anything obvious.  As for the Sky Assurance program, I spoke with a customer support rep at Meade (his name is Davidson) and he advised that the Sky Assurance program would not include any shipping, shipping insurance, or brokerage to and from Canada.  ::)  UPS has advised me that, even though the item is being returned for repair, brokerage fees still apply.  I will take your advice and call Canada Customs to see what they say.

Dave

#5 Guest_davidleejenkins_*

Guest_davidleejenkins_*
  • Guests

Posted 11 May 2008 - 10:42 AM

I took the bottom cover plate off the RCX400 and didn't notice anything out of the ordinary.  My dealer in Toronto has agreed to take a look at it to see if they can figure anything out.  I am dropping it off tomorrow and hope they can resolve this without me having to send it back to Meade.  I will let you know the outcome.

Dave




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users